{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-5992 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-5992 is a low-severity denial of service vulnerability in Qt, published on 11 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-5992 and fix it if it is affected.\n\nWhat it is: CVE-2025-5992 is a low-severity denial of service vulnerability in Qt, published on 11 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-5992 in the wild and no public exploit code.\n\nAffected product: Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5992/ (Markdown: https://insights.sbomify.com/CVE-2025-5992/index.md)","id":"CVE-2025-5992","markdown":"https://insights.sbomify.com/CVE-2025-5992/index.md","name":"CVE-2025-5992","record":{"aliases":["DEBIAN-CVE-2025-5992","GHSA-45wh-m547-4rh9","UBUNTU-CVE-2025-5992","openSUSE-SU-2025:15345-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Qt GUI library","requires_auth":"none","summary":"Attackers can cause a denial of service in Qt applications by providing crafted ICC profiles to QColorSpace::fromICCProfile, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"TQtC","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"When passing values outside of the expected range to QColorTransferGenericFunction it can cause a denial of service, for example, this can happen when passing a specifically crafted ICC profile to QColorSpace::fromICCProfile.\n\nThis issue affects Qt from 6.6.0 through 6.8.3, from 6.9.0 through 6.9.1. This is fixed in 6.8.4 and 6.9.2.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Passing values outside of expected range to QColorTransferGenericFunction can cause a denial of service","id":"CVE-2025-5992","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Path Traversal in ITCube CRM","id":"CVE-2025-5993"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.9.1-2.1"],"introduced":["0"],"last_affected":[],"package":"qt6-base","purl":"pkg:rpm/opensuse/qt6-base\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15345-1"}],"prev":{"headline":"Use after free in QHttp2ProtocolHandler","id":"CVE-2025-5991"},"products":["Qt"],"published":"2025-07-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-29","vendors":["Qt"]},"summary":"Attackers can cause a denial of service in Qt applications by providing crafted ICC profiles to QColorSpace::fromICCProfile, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2025-5992/"}