# CVE-2025-5992: Passing values outside of expected range to QColorTransferGenericFunction can cause a denial of service

> Attackers can cause a denial of service in Qt applications by providing crafted ICC profiles to QColorSpace::fromICCProfile, requiring an upgrade to patched versions.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jul 2025
- **Updated:** 29 Jul 2026
- **Also known as:** DEBIAN-CVE-2025-5992, GHSA-45wh-m547-4rh9, UBUNTU-CVE-2025-5992, openSUSE-SU-2025:15345-1

## What is CVE-2025-5992?

CVE-2025-5992 is a low-severity denial of service vulnerability in Qt, published on 11 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

When passing values outside of the expected range to QColorTransferGenericFunction it can cause a denial of service, for example, this can happen when passing a specifically crafted ICC profile to QColorSpace::fromICCProfile.

This issue affects Qt from 6.6.0 through 6.8.3, from 6.9.0 through 6.9.1. This is fixed in 6.8.4 and 6.9.2.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-5992?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qt6-base` | openSUSE:Tumbleweed | All versions | 6.9.1-2.1 |

## How do I fix CVE-2025-5992?

Upgrade to a fixed version.

## Is CVE-2025-5992 being exploited?

There is no known exploitation of CVE-2025-5992 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5992 and fix it if it is affected.

What it is: CVE-2025-5992 is a low-severity denial of service vulnerability in Qt, published on 11 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-5992 in the wild and no public exploit code.

Affected product: Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5992/ (Markdown: https://insights.sbomify.com/CVE-2025-5992/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5992
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5992
- OSV: https://osv.dev/vulnerability/CVE-2025-5992

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5992/
Summaries are generated and may contain mistakes; the official description above is the record.
