{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-59933 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-59933 is a medium-severity memory corruption vulnerability in libvips, published on 29 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59933 and fix it if it is affected.\n\nWhat it is: CVE-2025-59933 is a medium-severity memory corruption vulnerability in libvips, published on 29 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59933 in the wild and no public exploit code.\n\nAffected product: libvips. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59933/ (Markdown: https://insights.sbomify.com/CVE-2025-59933/index.md)","id":"CVE-2025-59933","markdown":"https://insights.sbomify.com/CVE-2025-59933/index.md","name":"CVE-2025-59933","record":{"aliases":["DEBIAN-CVE-2025-59933","GHSA-q8px-4w5q-c2r4","UBUNTU-CVE-2025-59933"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Image processing library","requires_auth":"none","summary":"A buffer over-read in libvips allows attackers to cause denial of service or disclose information via crafted PDFs when poppler support is enabled.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"libvips","vendor":"libvips"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-126","name":"Buffer Over-read"}],"description":"libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libvips is vulnerable to Buffer Over-Read in poppler-based pdfload","id":"CVE-2025-59933","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"Formbricks missing JWT signature verification","id":"CVE-2025-59934"},"packages":[],"prev":{"headline":"FlagForgeCTF Unauthenticated Resource Modification/Deletion","id":"CVE-2025-59932"},"products":["libvips"],"published":"2025-09-29","related":[{"cvss_score":8.8,"headline":"Use after free in n/a","id":"CVE-2019-17534","kev_date_added":null,"published":"2019-10-13"},{"cvss_score":7,"headline":"Possible integer overflow leading to potential heap-based buffer overflow","id":"CVE-2026-33327","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":7,"headline":"Possible heap-based buffer overflow when decoding TIFF image containing well-crafted tile","id":"CVE-2026-35591","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":6.8,"headline":"Possible integer overflow on 32-bit systems when reading GIF images","id":"CVE-2026-33328","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":6.8,"headline":"Possible out-of-bounds read leading to crash when decoding well-crafted EXIF metadata","id":"CVE-2026-35590","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":6.5,"headline":"Denial of service in n/a","id":"CVE-2021-27847","kev_date_added":null,"published":"2021-07-15"},{"cvss_score":5.3,"headline":"Information disclosure in n/a","id":"CVE-2019-6976","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-24","vendors":["libvips"]},"summary":"A buffer over-read in libvips allows attackers to cause denial of service or disclose information via crafted PDFs when poppler support is enabled.","url":"https://insights.sbomify.com/CVE-2025-59933/"}