# CVE-2025-59933: libvips is vulnerable to Buffer Over-Read in poppler-based pdfload

> A buffer over-read in libvips allows attackers to cause denial of service or disclose information via crafted PDFs when poppler support is enabled.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2025
- **Updated:** 24 Dec 2025
- **Also known as:** DEBIAN-CVE-2025-59933, GHSA-q8px-4w5q-c2r4, UBUNTU-CVE-2025-59933

## What is CVE-2025-59933?

CVE-2025-59933 is a medium-severity memory corruption vulnerability in libvips, published on 29 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.

Weakness: CWE-126 (Buffer Over-read)

## Which versions are affected by CVE-2025-59933?

It affects 1 product.


Products: Libvips Libvips.

## How do I fix CVE-2025-59933?

Upgrade to a fixed version.

## Is CVE-2025-59933 being exploited?

There is no known exploitation of CVE-2025-59933 in the wild and no public exploit code.

## Other vulnerabilities in libvips

- [CVE-2019-17534](https://insights.sbomify.com/CVE-2019-17534/): Use after free in n/a (high 8.8)
- [CVE-2026-33327](https://insights.sbomify.com/CVE-2026-33327/): Possible integer overflow leading to potential heap-based buffer overflow (high 7.0)
- [CVE-2026-35591](https://insights.sbomify.com/CVE-2026-35591/): Possible heap-based buffer overflow when decoding TIFF image containing well-crafted tile (high 7.0)
- [CVE-2026-33328](https://insights.sbomify.com/CVE-2026-33328/): Possible integer overflow on 32-bit systems when reading GIF images (medium 6.8)
- [CVE-2026-35590](https://insights.sbomify.com/CVE-2026-35590/): Possible out-of-bounds read leading to crash when decoding well-crafted EXIF metadata (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59933 and fix it if it is affected.

What it is: CVE-2025-59933 is a medium-severity memory corruption vulnerability in libvips, published on 29 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59933 in the wild and no public exploit code.

Affected product: libvips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59933/ (Markdown: https://insights.sbomify.com/CVE-2025-59933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59933
- OSV: https://osv.dev/vulnerability/CVE-2025-59933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59933/
Summaries are generated and may contain mistakes; the official description above is the record.
