CVE-2025-59935 GLPI Vulnerable to Unauthenticated Stored XSS on the Inventory page

Medium 6.5 Published Updated

An unauthenticated attacker can inject malicious scripts via the inventory endpoint, potentially compromising user sessions and data in GLPI.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-59935?

CVE-2025-59935 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.21, an unauthenticated user can store an XSS payload through the inventory endpoint. Users should upgrade to 10.0.21 to receive a patch.

Weakness: CWE-79

Which versions are affected by CVE-2025-59935?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2025-59935?

No fix has been published for CVE-2025-59935 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-59935 being exploited?

There is no known exploitation of CVE-2025-59935 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-j8vv-9f8m-r7jx, UBUNTU-CVE-2025-59935.

Is CVE-2025-59935 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free