{"answers":{"affected":"3 open source packages ship an affected version, including mkdocs-include-markdown-plugin.","exploited":"There is no known exploitation of CVE-2025-59940 in the wild and no public exploit code.","fix":"Upgrade mkdocs-include-markdown-plugin to 7.1.8 or later.","what":"CVE-2025-59940 is a medium-severity vulnerability in mondeja mkdocs-include-markdown-plugin, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59940 and fix it if it is affected.\n\nWhat it is: CVE-2025-59940 is a medium-severity vulnerability in mondeja mkdocs-include-markdown-plugin, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59940 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mkdocs-include-markdown-plugin (PyPI): affected all versions; fixed in 7.1.8\n- mkdocs-include-markdown-plugin (PyPI): affected all versions; fixed in 7.1.8\n- mkdocs-include-markdown-plugin (PyPI): affected all versions; fixed in 7.1.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59940/ (Markdown: https://insights.sbomify.com/CVE-2025-59940/index.md)","id":"CVE-2025-59940","markdown":"https://insights.sbomify.com/CVE-2025-59940/index.md","name":"CVE-2025-59940","record":{"aliases":["GHSA-v39m-5m9j-m9w9","PYSEC-2026-1632"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"MkDocs plugin","requires_auth":"none","summary":"Attackers can manipulate substitution placeholders via unvalidated input, potentially altering rendered content in MkDocs sites.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders","id":"CVE-2025-59940","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"go-f3 is Vulnerable to Cached Justification Verification Bypass","id":"CVE-2025-59941"},"packages":[{"ecosystem":"PyPI","fixed":["7.1.8"],"introduced":["0"],"last_affected":[],"package":"mkdocs-include-markdown-plugin","purl":null,"source":"GHSA-v39m-5m9j-m9w9"},{"ecosystem":"PyPI","fixed":["7.1.8"],"introduced":["0"],"last_affected":[],"package":"mkdocs-include-markdown-plugin","purl":"pkg:pypi/mkdocs-include-markdown-plugin","source":"GHSA-v39m-5m9j-m9w9"},{"ecosystem":"PyPI","fixed":["7.1.8"],"introduced":["0"],"last_affected":[],"package":"mkdocs-include-markdown-plugin","purl":"pkg:pypi/mkdocs-include-markdown-plugin","source":"PYSEC-2026-1632"}],"prev":{"headline":"WeGIA vulnerable to SQL Injection into method `excluir` of the `ProdutoControle` class in the parameter `id_produto`.","id":"CVE-2025-59939"},"products":["mkdocs-include-markdown-plugin"],"published":"2025-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-30","vendors":["mondeja"]},"summary":"Attackers can manipulate substitution placeholders via unvalidated input, potentially altering rendered content in MkDocs sites.","url":"https://insights.sbomify.com/CVE-2025-59940/"}