CVE-2025-59943 phpMyFAQ duplicate email registration allows multiple accounts with the same email

High 8.1 Published Updated

Attackers can create multiple accounts with the same email, potentially leading to account takeover or privilege escalation due to ambiguous identity handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-59943?

CVE-2025-59943 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

phpMyFAQ is an open source FAQ web application. Versions 4.0-nightly-2025-10-03 and below do not enforce uniqueness of email addresses during user registration. This allows multiple distinct accounts to be created with the same email. Because email is often used as an identifier for password resets, notifications, and administrative actions, this flaw can cause account ambiguity and, in certain configurations, may lead to privilege escalation or account takeover. This issue is fixed in version 4.0.13.

Weakness: CWE-286, CWE-284

Which versions are affected by CVE-2025-59943?

2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.

PackageAffectedFixed in
thorsten/phpmyfaq PackagistFrom 4.0.74.0.13
thorsten/phpmyfaq PackagistFrom 4.0.74.0.13

Products include Phpmyfaq Phpmyfaq.

How do I fix CVE-2025-59943?

Upgrade thorsten/phpmyfaq to 4.0.13 or later.

Is CVE-2025-59943 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59943 exists.

All Phpmyfaq Phpmyfaq vulnerabilities

Sources

Also known as GHSA-9wj2-4hcm-r74j.

Is CVE-2025-59943 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free