# CVE-2025-59943: phpMyFAQ duplicate email registration allows multiple accounts with the same email

> Attackers can create multiple accounts with the same email, potentially leading to account takeover or privilege escalation due to ambiguous identity handling.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Oct 2025
- **Updated:** 3 Oct 2025
- **Also known as:** GHSA-9wj2-4hcm-r74j

## What is CVE-2025-59943?

CVE-2025-59943 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

phpMyFAQ is an open source FAQ web application. Versions 4.0-nightly-2025-10-03 and below do not enforce uniqueness of email addresses during user registration. This allows multiple distinct accounts to be created with the same email. Because email is often used as an identifier for password resets, notifications, and administrative actions, this flaw can cause account ambiguity and, in certain configurations, may lead to privilege escalation or account takeover. This issue is fixed in version 4.0.13.

Weakness: CWE-286 (Incorrect User Management), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-59943?

2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | From 4.0.7 | 4.0.13 |
| `thorsten/phpmyfaq` | Packagist | From 4.0.7 | 4.0.13 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2025-59943?

Upgrade thorsten/phpmyfaq to 4.0.13 or later.

## Is CVE-2025-59943 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59943 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59943 and fix it if it is affected.

What it is: CVE-2025-59943 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59943 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected from 4.0.7; fixed in 4.0.13
- thorsten/phpmyfaq (Packagist): affected from 4.0.7; fixed in 4.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59943/ (Markdown: https://insights.sbomify.com/CVE-2025-59943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59943
- OSV: https://osv.dev/vulnerability/CVE-2025-59943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59943/
Summaries are generated and may contain mistakes; the official description above is the record.
