CVE-2025-59944 Cursor IDE: Sensitive File Overwrite Bypass is Possible

High 8.1 Published Updated

Attackers can bypass case-sensitive file protections to overwrite sensitive configuration files via prompt injection, leading to remote code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-59944?

CVE-2025-59944 is a high-severity path traversal vulnerability in cursor, published on 3 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.

Weakness: CWE-178

Which versions are affected by CVE-2025-59944?

It affects 1 product.

Products include Anysphere Cursor.

How do I fix CVE-2025-59944?

No fix has been published for CVE-2025-59944 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-59944 being exploited?

There is no known exploitation of CVE-2025-59944 in the wild and no public exploit code.

Sources

Is CVE-2025-59944 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free