# CVE-2025-59945: SysReptor Susceptible to Privilege Escalation by Authenticated Users

> Authenticated non-admin users can escalate privileges to project admin, allowing unauthorized access to modify and delete other users' pentest projects.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Sep 2025
- **Updated:** 29 Sep 2025
- **Also known as:** GHSA-r6hm-59cq-gjg6

## What is CVE-2025-59945?

CVE-2025-59945 is a high-severity vulnerability in Syslifters sysreptor, published on 27 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SysReptor is a fully customizable pentest reporting platform. In versions from 2024.74 to before 2025.83, authenticated and unprivileged (non-admin) users can assign the is_project_admin permission to their own user. This allows users to read, modify and delete pentesting projects they are not members of and are therefore not supposed to access. This issue has been patched in version 2025.83.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-59945?

It affects 1 product.


Products: Syslifters Sysreptor.

## How do I fix CVE-2025-59945?

No fix has been published for CVE-2025-59945 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59945 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59945 exists.

## Other vulnerabilities in Syslifters sysreptor

- [CVE-2024-36076](https://insights.sbomify.com/CVE-2024-36076/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2025-66561](https://insights.sbomify.com/CVE-2025-66561/): SysReptor Vulnerable to an Authenticated Stored Cross-Site Scripting (XSS) (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59945 and fix it if it is affected.

What it is: CVE-2025-59945 is a high-severity vulnerability in Syslifters sysreptor, published on 27 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59945 exists.

Affected product: Syslifters sysreptor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59945/ (Markdown: https://insights.sbomify.com/CVE-2025-59945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59945
- OSV: https://osv.dev/vulnerability/CVE-2025-59945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59945/
Summaries are generated and may contain mistakes; the official description above is the record.
