# CVE-2025-59946: NanoMQ has a Use After Free vulnerability via sub info list

> A race condition in NanoMQ's subscription info list can cause a heap use-after-free crash, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Dec 2025
- **Updated:** 29 Dec 2025
- **Also known as:** GHSA-xg37-23w7-72p5

## What is CVE-2025-59946?

CVE-2025-59946 is a high-severity use after free vulnerability in nanomq, published on 27 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NanoMQ MQTT Broker (NanoMQ) is an Edge Messaging Platform. Prior to version 0.24.2, there is a classical data racing issue about sub info list which could result in heap use after free crash. This issue has been patched in version 0.24.2.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2025-59946?

It affects 1 product.


Products: Emqx Nanomq.

## How do I fix CVE-2025-59946?

No fix has been published for CVE-2025-59946 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59946 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59946 exists.

## Other vulnerabilities in nanomq

- [CVE-2024-42655](https://insights.sbomify.com/CVE-2024-42655/): Missing authorization in n/a (high 8.8)
- [CVE-2025-59947](https://insights.sbomify.com/CVE-2025-59947/): NanoMQ has Buffer Overflow (high 8.5)
- [CVE-2023-34488](https://insights.sbomify.com/CVE-2023-34488/): Memory corruption in n/a (high 8.0)
- [CVE-2026-32135](https://insights.sbomify.com/CVE-2026-32135/): NanoMQ has Heap Buffer Overflow in URI Parameter Parsing (high 7.7)
- [CVE-2026-36590](https://insights.sbomify.com/CVE-2026-36590/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59946 and fix it if it is affected.

What it is: CVE-2025-59946 is a high-severity use after free vulnerability in nanomq, published on 27 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59946 exists.

Affected product: nanomq. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59946/ (Markdown: https://insights.sbomify.com/CVE-2025-59946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59946
- OSV: https://osv.dev/vulnerability/CVE-2025-59946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59946/
Summaries are generated and may contain mistakes; the official description above is the record.
