# CVE-2025-59947: NanoMQ has Buffer Overflow

> A buffer overflow in NanoMQ allows attackers to execute arbitrary code or cause denial of service via crafted PUBLISH packets.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Dec 2025
- **Updated:** 15 Dec 2025
- **Also known as:** GHSA-98f4-cmg8-x7f3

## What is CVE-2025-59947?

CVE-2025-59947 is a high-severity memory corruption vulnerability in nanomq, published on 15 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

NanoMQ is a messaging broker/bus for IoT Edge & SDV. Versions prior to 0.24.4 have a buffer overflow case while the PUBLISH packets trigger both shared subscription and vanila subscription. This is fixed in version 0.24.4. As a workaround, disable shared subscription.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2025-59947?

It affects 1 product.


Products: Emqx Nanomq.

## How do I fix CVE-2025-59947?

No fix has been published for CVE-2025-59947 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59947 being exploited?

There is no known exploitation of CVE-2025-59947 in the wild and no public exploit code.

## Other vulnerabilities in nanomq

- [CVE-2024-42655](https://insights.sbomify.com/CVE-2024-42655/): Missing authorization in n/a (high 8.8)
- [CVE-2023-34488](https://insights.sbomify.com/CVE-2023-34488/): Memory corruption in n/a (high 8.0)
- [CVE-2026-32135](https://insights.sbomify.com/CVE-2026-32135/): NanoMQ has Heap Buffer Overflow in URI Parameter Parsing (high 7.7)
- [CVE-2026-36590](https://insights.sbomify.com/CVE-2026-36590/): Denial of service in n/a (high 7.5)
- [CVE-2026-21888](https://insights.sbomify.com/CVE-2026-21888/): MQTT v5 Variable Byte Integer parsing out-of-bounds: get_var_integer() (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59947 and fix it if it is affected.

What it is: CVE-2025-59947 is a high-severity memory corruption vulnerability in nanomq, published on 15 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59947 in the wild and no public exploit code.

Affected product: nanomq. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59947/ (Markdown: https://insights.sbomify.com/CVE-2025-59947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59947
- OSV: https://osv.dev/vulnerability/CVE-2025-59947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59947/
Summaries are generated and may contain mistakes; the official description above is the record.
