# CVE-2025-59952: minio-java Client XML Tag is Vulnerable to Value Substitution

> Attackers can expose sensitive system properties or environment variables via crafted XML content in the MinIO Java SDK.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2025
- **Updated:** 23 Jan 2026
- **Also known as:** GHSA-h7rh-xfpj-hpcm

## What is CVE-2025-59952?

CVE-2025-59952 is a high-severity vulnerability in minio-java, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MinIO Java SDK is a Simple Storage Service (aka S3) client to perform bucket and object operations to any Amazon S3 compatible object storage service. In minio-java versions prior to 8.6.0, XML tag values containing references to system properties or environment variables were automatically substituted with their actual values during processing. This unintended behavior could lead to the exposure of sensitive information, including credentials, file paths, or system configuration details, if such references were present in XML content from untrusted sources. This is fixed in version 8.6.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-59952?

2 open source packages ship an affected version, including io.minio:minio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.minio:minio` | Maven | All versions | 8.6.0 |
| `io.minio:minio` | Maven | All versions | 8.6.0 |

## How do I fix CVE-2025-59952?

Upgrade io.minio:minio to 8.6.0 or later.

## Is CVE-2025-59952 being exploited?

There is no known exploitation of CVE-2025-59952 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59952 and fix it if it is affected.

What it is: CVE-2025-59952 is a high-severity vulnerability in minio-java, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59952 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.minio:minio (Maven): affected all versions; fixed in 8.6.0
- io.minio:minio (Maven): affected all versions; fixed in 8.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59952/ (Markdown: https://insights.sbomify.com/CVE-2025-59952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59952
- OSV: https://osv.dev/vulnerability/CVE-2025-59952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59952/
Summaries are generated and may contain mistakes; the official description above is the record.
