# CVE-2025-59953: LMdeploy has Remote Code Execution by Pickle Deserialization via zmq_rpc.call_and_response() in InterLM/lmdeploy

> Remote attackers can execute arbitrary code by sending malicious pickle data to the RPC server in LMdeploy.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-5h8j-6crg-7rmw, PYSEC-2026-4079

## What is CVE-2025-59953?

CVE-2025-59953 is a critical unsafe deserialization vulnerability in InternLM lmdeploy, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LMDeploy is a toolkit for compressing, deploying, and serving large language models. Starting in version 0.9.1 and prior to version 0.10.2, the LMdeploy implements an rpc server (AsyncRPCServer in zmq_rpc.py) for supporting the RPC communications. In its core functionality call_and_response(), I found it will directly use the pickles.loads() to deserialize the received messages without any sanitization, hence resulting in a remote code execution vulnerability by this RPC server. Version 0.10.2 contains a patch.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-59953?

3 open source packages ship an affected version, including lmdeploy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lmdeploy` | PyPI | From 0.9.1 | 0.10.2 |
| `lmdeploy` | PyPI | From 0.9.1 | 0.10.2 |
| `lmdeploy` | PyPI | From 0.9.1 | 0.10.2 |

## How do I fix CVE-2025-59953?

Upgrade lmdeploy to 0.10.2 or later.

## Is CVE-2025-59953 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59953 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59953 and fix it if it is affected.

What it is: CVE-2025-59953 is a critical unsafe deserialization vulnerability in InternLM lmdeploy, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59953 exists.

Affected packages and fixed versions:
- lmdeploy (PyPI): affected from 0.9.1; fixed in 0.10.2
- lmdeploy (PyPI): affected from 0.9.1; fixed in 0.10.2
- lmdeploy (PyPI): affected from 0.9.1; fixed in 0.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59953/ (Markdown: https://insights.sbomify.com/CVE-2025-59953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59953
- OSV: https://osv.dev/vulnerability/CVE-2025-59953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59953/
Summaries are generated and may contain mistakes; the official description above is the record.
