CVE-2025-59954 Knowage Contains a Remote Code Execution Vulnerability

Critical 9.3 Published Updated

Attackers can execute arbitrary code remotely in Knowage BI suite via unsafe JXPath usage, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-59954?

CVE-2025-59954 is a critical code injection vulnerability in KnowageLabs Knowage-Server, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Knowage is an open source analytics and business intelligence suite. Versions 8.1.26 and below are vulnerable to Remote Code Exection through using an unsafe org.apache.commons.jxpath.JXPathContext in MetaService.java service. This issue is fixed in version 8.1.27.

Weakness: CWE-94

Which versions are affected by CVE-2025-59954?

It affects 1 product.

Products include Eng Knowage.

How do I fix CVE-2025-59954?

No fix has been published for CVE-2025-59954 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-59954 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59954 exists.

Sources

Also known as GHSA-96cv-75hg-xrgq.

Is CVE-2025-59954 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free