{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59954 exists.","fix":"No fix has been published for CVE-2025-59954 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-59954 is a critical code injection vulnerability in KnowageLabs Knowage-Server, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59954 and fix it if it is affected.\n\nWhat it is: CVE-2025-59954 is a critical code injection vulnerability in KnowageLabs Knowage-Server, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59954 exists.\n\nAffected product: KnowageLabs Knowage-Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59954/ (Markdown: https://insights.sbomify.com/CVE-2025-59954/index.md)","id":"CVE-2025-59954","markdown":"https://insights.sbomify.com/CVE-2025-59954/index.md","name":"CVE-2025-59954","record":{"aliases":["GHSA-96cv-75hg-xrgq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Knowage BI suite","requires_auth":"none","summary":"Attackers can execute arbitrary code remotely in Knowage BI suite via unsafe JXPath usage, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"knowage","vendor":"eng"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Knowage is an open source analytics and business intelligence suite. Versions 8.1.26 and below are vulnerable to Remote Code Exection through using an unsafe org.apache.commons.jxpath.JXPathContext in MetaService.java service. This issue is fixed in version 8.1.27.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Knowage Contains a Remote Code Execution Vulnerability","id":"CVE-2025-59954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Coolify leaksensitive information `email_change_code` in `/api/v1/teams/{team_id | current}/members` API endpoint","id":"CVE-2025-59955"},"packages":[],"prev":{"headline":"LMdeploy has Remote Code Execution by Pickle Deserialization via zmq_rpc.call_and_response() in InterLM/lmdeploy","id":"CVE-2025-59953"},"products":["Knowage-Server"],"published":"2025-09-29","related":[{"cvss_score":10,"headline":"Knowage Server vulnerable to path traversal via upload functionality","id":"CVE-2023-38702","kev_date_added":null,"published":"2023-08-04"},{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2019-13188","kev_date_added":null,"published":"2019-09-05"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2021-30055","kev_date_added":null,"published":"2021-04-05"},{"cvss_score":8.8,"headline":"Information disclosure in n/a","id":"CVE-2019-13348","kev_date_added":null,"published":"2019-08-28"},{"cvss_score":7.7,"headline":"Query injection in Knowage server","id":"CVE-2023-37472","kev_date_added":null,"published":"2023-07-14"},{"cvss_score":7.2,"headline":"Knowage-Server vulnerable to account validation bypass","id":"CVE-2023-35154","kev_date_added":null,"published":"2023-06-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-30","vendors":["KnowageLabs"]},"summary":"Attackers can execute arbitrary code remotely in Knowage BI suite via unsafe JXPath usage, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2025-59954/"}