# CVE-2025-59954: Knowage Contains a Remote Code Execution Vulnerability

> Attackers can execute arbitrary code remotely in Knowage BI suite via unsafe JXPath usage, requiring an upgrade to the latest version.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Sep 2025
- **Updated:** 30 Sep 2025
- **Also known as:** GHSA-96cv-75hg-xrgq

## What is CVE-2025-59954?

CVE-2025-59954 is a critical code injection vulnerability in KnowageLabs Knowage-Server, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Knowage is an open source analytics and business intelligence suite. Versions 8.1.26 and below are vulnerable to Remote Code Exection through using an unsafe org.apache.commons.jxpath.JXPathContext in MetaService.java service. This issue is fixed in version 8.1.27.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-59954?

It affects 1 product.


Products: Eng Knowage.

## How do I fix CVE-2025-59954?

No fix has been published for CVE-2025-59954 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59954 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59954 exists.

## Other vulnerabilities in KnowageLabs Knowage-Server

- [CVE-2023-38702](https://insights.sbomify.com/CVE-2023-38702/): Knowage Server vulnerable to path traversal via upload functionality (critical 10.0)
- [CVE-2019-13188](https://insights.sbomify.com/CVE-2019-13188/): Auth bypass in n/a (critical 9.8)
- [CVE-2021-30055](https://insights.sbomify.com/CVE-2021-30055/): SQL injection in n/a (high 8.8)
- [CVE-2019-13348](https://insights.sbomify.com/CVE-2019-13348/): Information disclosure in n/a (high 8.8)
- [CVE-2023-37472](https://insights.sbomify.com/CVE-2023-37472/): Query injection in Knowage server (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59954 and fix it if it is affected.

What it is: CVE-2025-59954 is a critical code injection vulnerability in KnowageLabs Knowage-Server, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59954 exists.

Affected product: KnowageLabs Knowage-Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59954/ (Markdown: https://insights.sbomify.com/CVE-2025-59954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59954
- OSV: https://osv.dev/vulnerability/CVE-2025-59954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59954/
Summaries are generated and may contain mistakes; the official description above is the record.
