CVE-2025-6000 Arbitrary Remote Code Execution via Plugin Catalog Abuse
Privileged Vault operators can achieve remote code execution on the host if a plugin directory is configured, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6000?
CVE-2025-6000 is a critical code injection vulnerability in Hashicorp Vault, published on 1 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A privileged Vault operator within the root namespace with write permission to {{sys/audit}} may obtain code execution on the underlying host if a plugin directory is set in Vault’s configuration. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
Weakness: CWE-94
Which versions are affected by CVE-2025-6000?
4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/vault Go | From 0.8.0 | 1.20.1 |
github.com/hashicorp/vault Go | From 0.8.0 | 1.20.1 |
github.com/hashicorp/vault Go | From 0.8.0 | 1.20.1 |
vault Bitnami | From 0.8.0 | 1.20.1 |
Products include Hashicorp Vault.
How do I fix CVE-2025-6000?
Upgrade github.com/hashicorp/vault to 1.20.1 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-6000 being exploited?
There is no known exploitation of CVE-2025-6000 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
Sources
Also known as BIT-vault-2025-6000, CLEANSTART-2026-BI76968, GHSA-mr4h-qf9j-f665, GO-2025-3838, MINI-hp3v-jh88-v63v.