# CVE-2025-60012: Apache Livy: Restrict file access

> Attackers with REST or JDBC access can manipulate Spark configurations to read unauthorized files in Apache Livy.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2026
- **Updated:** 13 Mar 2026
- **Also known as:** GHSA-hm8x-rpgg-7855

## What is CVE-2025-60012?

CVE-2025-60012 is a medium-severity path traversal vulnerability in Apache Livy, published on 13 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Malicious configuration can lead to unauthorized file access in Apache Livy.

This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later.

A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to.

For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values.

Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-60012?

2 open source packages ship an affected version, including org.apache.livy:livy-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.livy:livy-server` | Maven | From 0.7.0-incubating | 0.9.0-incubating |
| `org.apache.livy:livy-server` | Maven | From 0.7.0-incubating | 0.9.0-incubating |

Products: Apache Livy.

## How do I fix CVE-2025-60012?

Upgrade org.apache.livy:livy-server to 0.9.0-incubating or later.

## Is CVE-2025-60012 being exploited?

There is no known exploitation of CVE-2025-60012 in the wild and no public exploit code.

Public exploit code:

- A POC for the Apache Livy Unauthorized File Access Vunerability (github_poc): https://github.com/sid6224/CVE-2025-60012-POC

## Other vulnerabilities in Apache Livy

- [CVE-2025-66249](https://insights.sbomify.com/CVE-2025-66249/): Apache Livy: Unauthorized directory access (medium 6.3)
- [CVE-2021-26544](https://insights.sbomify.com/CVE-2021-26544/): Apache Livy (Incubating) is vulnerable to cross site scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-60012 and fix it if it is affected.

What it is: CVE-2025-60012 is a medium-severity path traversal vulnerability in Apache Livy, published on 13 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-60012 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.livy:livy-server (Maven): affected from 0.7.0-incubating; fixed in 0.9.0-incubating
- org.apache.livy:livy-server (Maven): affected from 0.7.0-incubating; fixed in 0.9.0-incubating

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-60012/ (Markdown: https://insights.sbomify.com/CVE-2025-60012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-60012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-60012
- OSV: https://osv.dev/vulnerability/CVE-2025-60012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-60012/
Summaries are generated and may contain mistakes; the official description above is the record.
