CVE-2025-6004 Vault Userpass and LDAP User Lockout Bypass
Attackers can bypass user lockout mechanisms in Vault's Userpass and LDAP authentication methods, allowing continued brute-force attempts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6004?
CVE-2025-6004 is a medium-severity vulnerability in Hashicorp Vault, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vault and Vault Enterprise’s (“Vault”) user lockout feature could be bypassed for Userpass and LDAP authentication methods. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
Weakness: CWE-307
Which versions are affected by CVE-2025-6004?
4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/vault Go | From 1.13.0 | 1.20.1 |
github.com/hashicorp/vault Go | From 1.13.0 | 1.20.1 |
github.com/hashicorp/vault Go | From 1.13.0 | 1.20.1 |
vault Bitnami | From 1.13.0 | 1.20.1 |
Products include Hashicorp Vault.
How do I fix CVE-2025-6004?
Upgrade github.com/hashicorp/vault to 1.20.1 or later.
Is CVE-2025-6004 being exploited?
There is no known exploitation of CVE-2025-6004 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
Sources
Also known as BIT-vault-2025-6004, GHSA-qgj7-fmq2-6cc4, GO-2025-3840, MINI-mxhx-w778-v787.