# CVE-2025-6004: Vault Userpass and LDAP User Lockout Bypass

> Attackers can bypass user lockout mechanisms in Vault's Userpass and LDAP authentication methods, allowing continued brute-force attempts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2025
- **Updated:** 1 Aug 2025
- **Also known as:** BIT-vault-2025-6004, GHSA-qgj7-fmq2-6cc4, GO-2025-3840, MINI-mxhx-w778-v787

## What is CVE-2025-6004?

CVE-2025-6004 is a medium-severity vulnerability in Hashicorp Vault, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vault and Vault Enterprise’s (“Vault”) user lockout feature could be bypassed for Userpass and LDAP authentication methods. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-6004?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.13.0 | 1.20.1 |
| `github.com/hashicorp/vault` | Go | From 1.13.0 | 1.20.1 |
| `github.com/hashicorp/vault` | Go | From 1.13.0 | 1.20.1 |
| `vault` | Bitnami | From 1.13.0 | 1.20.1 |

Products: Hashicorp Vault.

## How do I fix CVE-2025-6004?

Upgrade github.com/hashicorp/vault to 1.20.1 or later.

## Is CVE-2025-6004 being exploited?

There is no known exploitation of CVE-2025-6004 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6004 and fix it if it is affected.

What it is: CVE-2025-6004 is a medium-severity vulnerability in Hashicorp Vault, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6004 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.13.0; fixed in 1.20.1
- github.com/hashicorp/vault (Go): affected from 1.13.0; fixed in 1.20.1
- github.com/hashicorp/vault (Go): affected from 1.13.0; fixed in 1.20.1
- vault (Bitnami): affected from 1.13.0; fixed in 1.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6004/ (Markdown: https://insights.sbomify.com/CVE-2025-6004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6004
- OSV: https://osv.dev/vulnerability/CVE-2025-6004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6004/
Summaries are generated and may contain mistakes; the official description above is the record.
