CVE-2025-6014 Vault TOTP Secrets Engine Code Reuse
Attackers can reuse TOTP codes within their validity period, bypassing two-factor authentication controls in HashiCorp Vault.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6014?
CVE-2025-6014 is a medium-severity vulnerability in Hashicorp Vault, published on 1 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Vault and Vault Enterprise’s (“Vault”) TOTP Secrets Engine code validation endpoint is susceptible to code reuse within its validity period. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
Weakness: CWE-156
Which versions are affected by CVE-2025-6014?
4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/vault Go | All versions | 1.20.1 |
github.com/hashicorp/vault Go | All versions | 1.20.1 |
github.com/hashicorp/vault Go | All versions | 1.20.1 |
vault Bitnami | All versions | 1.20.1 |
Products include Hashicorp Vault.
How do I fix CVE-2025-6014?
Upgrade github.com/hashicorp/vault to 1.20.1 or later.
Is CVE-2025-6014 being exploited?
There is no known exploitation of CVE-2025-6014 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
Sources
Also known as BIT-vault-2025-6014, CLEANSTART-2026-RG79000, GHSA-qv3p-fmv3-9hww, GO-2025-3841, MINI-gvqm-h5m6-8wp2.