# CVE-2025-6032: Podman: podman missing tls verification

> Podman fails to verify TLS certificates during VM image downloads, allowing attackers to perform Man-in-the-Middle attacks to intercept or modify data.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2025
- **Updated:** 12 Oct 2026
- **Also known as:** ALSA-2025:10549, ALSA-2025:10550, ALSA-2025:10551, AZL-64454, DEBIAN-CVE-2025-6032, GHSA-65gg-3w2w-hr4h, GO-2025-3777, MINI-g5g6-rv37-2p4h, OESA-2026-3402, RHSA-2025:10549, RHSA-2025:10550, RHSA-2025:10551, RHSA-2025:10668, RHSA-2025:9726, RHSA-2025:9751, RHSA-2025:9766, RLSA-2025:10549, RLSA-2025:10550, RLSA-2025:10551, SUSE-SU-2025:02806-1, SUSE-SU-2025:02807-1, SUSE-SU-2025:02808-1, SUSE-SU-2025:20692-1, SUSE-SU-2025:20805-1, UBUNTU-CVE-2025-6032, openSUSE-SU-2025:15262-1

## What is CVE-2025-6032?

CVE-2025-6032 is a high-severity vulnerability in Red Hat Enterprise Linux 10, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Podman. The podman machine init command fails to verify the TLS certificate when downloading the VM images from an OCI registry. This issue results in a Man In The Middle attack.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2025-6032?

9 open source packages ship an affected version, including github.com/containers/podman/v4, github.com/containers/podman and github.com/containers/podman/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman/v4` | Go | From 4.8.0 | None |
| `github.com/containers/podman/v4` | Go | From 4.8.0 to 4.9.5 | None |
| `github.com/containers/podman/v4` | Go | From 4.8.0 to 4.9.5 | None |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions | None |
| `github.com/containers/podman/v5` | Go | All versions | 5.5.2 |
| `github.com/containers/podman/v5` | Go | All versions | 5.5.2 |
| `github.com/containers/podman/v5` | Go | All versions | 5.5.2 |
| `podman-docker` | AlmaLinux:10 | All versions | 6:5.4.0-12.el10_0 |
| `aardvark-dns` | AlmaLinux:8 | All versions | 2:1.10.1-2.module_el8.10.0+3909+6e1c1eb7 |
| `aardvark-dns` | AlmaLinux:8 | All versions | 2:1.10.1-2.module_el8.10.0+4016+efd18bf8 |
| `aardvark-dns` | AlmaLinux:8 | All versions | 2:1.10.1-2.module_el8.10.0+4023+db236c53 |
| `buildah` | AlmaLinux:8 | All versions | 2:1.33.12-2.module_el8.10.0+4016+efd18bf8 |
| `buildah` | AlmaLinux:8 | All versions | 2:1.33.12-2.module_el8.10.0+4023+db236c53 |
| `buildah-tests` | AlmaLinux:8 | All versions | 2:1.33.12-2.module_el8.10.0+4016+efd18bf8 |
| `buildah-tests` | AlmaLinux:8 | All versions | 2:1.33.12-2.module_el8.10.0+4023+db236c53 |
| `cockpit-podman` | AlmaLinux:8 | All versions | 84.1-1.module_el8.10.0+4016+efd18bf8 |
| `conmon` | AlmaLinux:8 | All versions | 3:2.1.10-1.module_el8.10.0+3970+8445edf6 |
| `container-selinux` | AlmaLinux:8 | All versions | 2:2.229.0-2.module_el8.10.0+3909+6e1c1eb7 |
| `containernetworking-plugins` | AlmaLinux:8 | All versions | 1:1.4.0-6.module_el8.10.0+4016+efd18bf8 |
| `containernetworking-plugins` | AlmaLinux:8 | All versions | 1:1.4.0-6.module_el8.10.0+4023+db236c53 |
| `containers-common` | AlmaLinux:8 | All versions | 2:1-82.module_el8.10.0+3876+e55593a8 |
| `containers-common` | AlmaLinux:8 | All versions | 2:1-82.module_el8.10.0+3901+4b80ecd7 |
| `containers-common` | AlmaLinux:8 | All versions | 2:1-82.module_el8.10.0+3970+8445edf6 |
| `containers-common` | AlmaLinux:8 | All versions | 2:1-82.module_el8.10.0+4023+db236c53 |
| `crit` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3845+87b84552 |
| `crit` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3858+6ad51f9f |
| `crit` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3901+4b80ecd7 |
| `criu` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3876+e55593a8 |
| `criu` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3909+6e1c1eb7 |
| `criu` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3926+f12484f5 |
| `criu` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3970+8445edf6 |
| `criu-devel` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3858+6ad51f9f |
| `criu-devel` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3876+e55593a8 |
| `criu-devel` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+4016+efd18bf8 |
| `criu-devel` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+4023+db236c53 |
| `criu-libs` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3909+6e1c1eb7 |
| `criu-libs` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3926+f12484f5 |
| `criu-libs` | AlmaLinux:8 | All versions | 3.18-5.module_el8.10.0+3970+8445edf6 |

## How do I fix CVE-2025-6032?

Apply the vendor's patch.

## Is CVE-2025-6032 being exploited?

There is no known exploitation of CVE-2025-6032 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6032 and fix it if it is affected.

What it is: CVE-2025-6032 is a high-severity vulnerability in Red Hat Enterprise Linux 10, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-6032 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman/v4 (Go): affected from 4.8.0; no fix listed
- github.com/containers/podman/v4 (Go): affected from 4.8.0 up to 4.9.5; no fix listed
- github.com/containers/podman/v4 (Go): affected from 4.8.0 up to 4.9.5; no fix listed
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.5.2
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.5.2
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6032/ (Markdown: https://insights.sbomify.com/CVE-2025-6032/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6032
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6032
- OSV: https://osv.dev/vulnerability/CVE-2025-6032

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6032/
Summaries are generated and may contain mistakes; the official description above is the record.
