{"answers":{"affected":"4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-6037 in the wild and no public exploit code.","fix":"Upgrade github.com/hashicorp/vault to 1.20.1 or later.","what":"CVE-2025-6037 is a medium-severity authentication bypass vulnerability in Hashicorp Vault, published on 1 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-6037 and fix it if it is affected.\n\nWhat it is: CVE-2025-6037 is a medium-severity authentication bypass vulnerability in Hashicorp Vault, published on 1 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-6037 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.1\n- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.1\n- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.1\n- vault (Bitnami): affected all versions; fixed in 1.20.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6037/ (Markdown: https://insights.sbomify.com/CVE-2025-6037/index.md)","id":"CVE-2025-6037","markdown":"https://insights.sbomify.com/CVE-2025-6037/index.md","name":"CVE-2025-6037","record":{"aliases":["BIT-vault-2025-6037","GHSA-6c5r-4wfc-3mcx","GO-2025-3836","MINI-whj8-4wpm-p4gj"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"HashiCorp Vault","requires_auth":"high_privilege","summary":"Attackers can impersonate users via crafted certificates when Vault uses a non-CA trusted certificate, requiring an upgrade to secure authentication.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HashiCorp","cpe":[{"product":"vault","vendor":"hashicorp"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Vault and Vault Enterprise (“Vault”) TLS certificate auth method did not correctly validate client certificates when configured with a non-CA certificate as [+trusted certificate+|https://developer.hashicorp.com/vault/api-docs/auth/cert#certificate]. In this configuration, an attacker may be able to craft a malicious certificate that could be used to impersonate another user. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vault Certificate Auth Method Did Not Validate Common Name For Non-CA Certificates","id":"CVE-2025-6037","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"hashicorp:vault","products":["hashicorp:vault"],"type":"auth_bypass","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"Privilege escalation in Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme","id":"CVE-2025-6038"},"packages":[{"ecosystem":"Bitnami","fixed":["1.20.1"],"introduced":["0"],"last_affected":[],"package":"vault","purl":"pkg:bitnami/vault","source":"BIT-vault-2025-6037"},{"ecosystem":"Go","fixed":["1.20.1"],"introduced":["0"],"last_affected":[],"package":"github.com/hashicorp/vault","purl":null,"source":"GHSA-6c5r-4wfc-3mcx"},{"ecosystem":"Go","fixed":["1.20.1"],"introduced":["0"],"last_affected":[],"package":"github.com/hashicorp/vault","purl":"pkg:golang/github.com/hashicorp/vault","source":"GHSA-6c5r-4wfc-3mcx"},{"ecosystem":"Go","fixed":["1.20.1"],"introduced":["0"],"last_affected":[],"package":"github.com/hashicorp/vault","purl":"pkg:golang/github.com/hashicorp/vault","source":"GO-2025-3836"}],"prev":{"headline":"Gimp: gimp integer overflow","id":"CVE-2025-6035"},"products":["Vault","Vault Enterprise"],"published":"2025-08-01","related":[{"cvss_score":9.8,"headline":"Hardcoded credentials in n/a","id":"CVE-2020-35192","kev_date_added":null,"published":"2020-12-17"},{"cvss_score":9.8,"headline":"Improper Input Validation in HashiCorp Vault","id":"CVE-2020-12757","kev_date_added":null,"published":"2020-06-10"},{"cvss_score":9.1,"headline":"Arbitrary Remote Code Execution via Plugin Catalog Abuse","id":"CVE-2025-6000","kev_date_added":null,"published":"2025-08-01"},{"cvss_score":9.1,"headline":"HashiCorp Vault vulnerable to incorrect metadata access","id":"CVE-2022-40186","kev_date_added":null,"published":"2022-09-22"},{"cvss_score":9.1,"headline":"Missing authorization in n/a","id":"CVE-2022-36129","kev_date_added":null,"published":"2022-07-26"},{"cvss_score":9.1,"headline":"HashiCorp Vault Improper Privilege Management","id":"CVE-2020-10661","kev_date_added":null,"published":"2020-03-23"},{"cvss_score":8.2,"headline":"Authentication Bypass by Spoofing and Insufficient Verification of Data Authenticity in Hashicorp Vault","id":"CVE-2020-16250","kev_date_added":null,"published":"2020-08-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["HashiCorp"]},"summary":"Attackers can impersonate users via crafted certificates when Vault uses a non-CA trusted certificate, requiring an upgrade to secure authentication.","url":"https://insights.sbomify.com/CVE-2025-6037/"}