# CVE-2025-6037: Vault Certificate Auth Method Did Not Validate Common Name For Non-CA Certificates

> Attackers can impersonate users via crafted certificates when Vault uses a non-CA trusted certificate, requiring an upgrade to secure authentication.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Aug 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-vault-2025-6037, GHSA-6c5r-4wfc-3mcx, GO-2025-3836, MINI-whj8-4wpm-p4gj

## What is CVE-2025-6037?

CVE-2025-6037 is a medium-severity authentication bypass vulnerability in Hashicorp Vault, published on 1 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Vault and Vault Enterprise (“Vault”) TLS certificate auth method did not correctly validate client certificates when configured with a non-CA certificate as [+trusted certificate+|https://developer.hashicorp.com/vault/api-docs/auth/cert#certificate]. In this configuration, an attacker may be able to craft a malicious certificate that could be used to impersonate another user. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2025-6037?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | All versions | 1.20.1 |
| `github.com/hashicorp/vault` | Go | All versions | 1.20.1 |
| `github.com/hashicorp/vault` | Go | All versions | 1.20.1 |
| `vault` | Bitnami | All versions | 1.20.1 |

Products: Hashicorp Vault.

## How do I fix CVE-2025-6037?

Upgrade github.com/hashicorp/vault to 1.20.1 or later.

## Is CVE-2025-6037 being exploited?

There is no known exploitation of CVE-2025-6037 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6037 and fix it if it is affected.

What it is: CVE-2025-6037 is a medium-severity authentication bypass vulnerability in Hashicorp Vault, published on 1 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-6037 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.1
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.1
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.1
- vault (Bitnami): affected all versions; fixed in 1.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6037/ (Markdown: https://insights.sbomify.com/CVE-2025-6037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6037
- OSV: https://osv.dev/vulnerability/CVE-2025-6037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6037/
Summaries are generated and may contain mistakes; the official description above is the record.
