{"answers":{"affected":"4 open source packages ship an affected version, including modular and max. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-60455 in the wild and no public exploit code.","fix":"Upgrade modular to 25.6.0 or later.","what":"CVE-2025-60455 is a high-severity unsafe deserialization vulnerability in n/a, published on 18 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-60455 and fix it if it is affected.\n\nWhat it is: CVE-2025-60455 is a high-severity unsafe deserialization vulnerability in n/a, published on 18 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-60455 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modular (PyPI): affected all versions; fixed in 25.6.0\n- modular (PyPI): affected all versions; fixed in 25.6.0\n- modular (PyPI): affected all versions; fixed in 25.6.0\n- max (PyPI): affected all versions; fixed in 25.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-60455/ (Markdown: https://insights.sbomify.com/CVE-2025-60455/index.md)","id":"CVE-2025-60455","markdown":"https://insights.sbomify.com/CVE-2025-60455/index.md","name":"CVE-2025-60455","record":{"aliases":["GHSA-7xcv-9j6c-2fmc","PYSEC-2025-253","PYSEC-2026-427"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Python ML serving library","requires_auth":"none","summary":"Attackers can execute arbitrary code via unsafe deserialization in Modular Max Serve when the experimental KV cache agent feature is enabled.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"max","vendor":"modular"}],"cvss":{"score":8.4,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the \"--experimental-enable-kvcache-agent\" feature is used allowing attackers to execute arbitrary code.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Modular Max Serve has Unsafe Deserialization vulnerability","id":"CVE-2025-60455","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":4,"n_references":6,"next":{"headline":"Use after free in n/a","id":"CVE-2025-60458"},"packages":[{"ecosystem":"PyPI","fixed":["25.6.0"],"introduced":["0"],"last_affected":[],"package":"max","purl":"pkg:pypi/max","source":"PYSEC-2025-253"},{"ecosystem":"PyPI","fixed":["25.6.0"],"introduced":["0"],"last_affected":[],"package":"modular","purl":null,"source":"GHSA-7xcv-9j6c-2fmc"},{"ecosystem":"PyPI","fixed":["25.6.0"],"introduced":["0"],"last_affected":[],"package":"modular","purl":"pkg:pypi/modular","source":"GHSA-7xcv-9j6c-2fmc"},{"ecosystem":"PyPI","fixed":["25.6.0"],"introduced":["0"],"last_affected":[],"package":"modular","purl":"pkg:pypi/modular","source":"PYSEC-2026-427"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2025-60454"},"products":["n/a"],"published":"2025-11-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-19","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via unsafe deserialization in Modular Max Serve when the experimental KV cache agent feature is enabled.","url":"https://insights.sbomify.com/CVE-2025-60455/"}