# CVE-2025-60455: Modular Max Serve has Unsafe Deserialization vulnerability

> Attackers can execute arbitrary code via unsafe deserialization in Modular Max Serve when the experimental KV cache agent feature is enabled.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 19 Nov 2025
- **Also known as:** GHSA-7xcv-9j6c-2fmc, PYSEC-2025-253, PYSEC-2026-427

## What is CVE-2025-60455?

CVE-2025-60455 is a high-severity unsafe deserialization vulnerability in n/a, published on 18 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the "--experimental-enable-kvcache-agent" feature is used allowing attackers to execute arbitrary code.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-60455?

4 open source packages ship an affected version, including modular and max. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modular` | PyPI | All versions | 25.6.0 |
| `modular` | PyPI | All versions | 25.6.0 |
| `modular` | PyPI | All versions | 25.6.0 |
| `max` | PyPI | All versions | 25.6.0 |

Products: Modular Max.

## How do I fix CVE-2025-60455?

Upgrade modular to 25.6.0 or later.

## Is CVE-2025-60455 being exploited?

There is no known exploitation of CVE-2025-60455 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-60455 and fix it if it is affected.

What it is: CVE-2025-60455 is a high-severity unsafe deserialization vulnerability in n/a, published on 18 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-60455 in the wild and no public exploit code.

Affected packages and fixed versions:
- modular (PyPI): affected all versions; fixed in 25.6.0
- modular (PyPI): affected all versions; fixed in 25.6.0
- modular (PyPI): affected all versions; fixed in 25.6.0
- max (PyPI): affected all versions; fixed in 25.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-60455/ (Markdown: https://insights.sbomify.com/CVE-2025-60455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-60455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-60455
- OSV: https://osv.dev/vulnerability/CVE-2025-60455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-60455/
Summaries are generated and may contain mistakes; the official description above is the record.
