# CVE-2025-6050: Stored Cross-Site Scripting (XSS) in Mezzanine CMS Admin Interface

> An authenticated admin can inject malicious scripts via blog titles, leading to script execution in other admins' browsers.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2025
- **Updated:** 24 Jul 2025
- **Also known as:** GHSA-7pr5-w74r-jjj7, PYSEC-2025-236

## What is CVE-2025-6050?

CVE-2025-6050 is a medium-severity cross-site scripting vulnerability in jupo mezzanine, published on 17 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Mezzanine CMS, in versions prior to 6.1.1, contains a Stored Cross-Site Scripting (XSS) vulnerability in the admin interface. The vulnerability exists in the "displayable_links_js" function, which fails to properly sanitize blog post titles before including them in JSON responses served via "/admin/displayable_links.js". An authenticated admin user can create a blog post with a malicious JavaScript payload in the title field, then trick another admin user into clicking a direct link to the "/admin/displayable_links.js" endpoint, causing the malicious script to execute in their browser.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-6050?

3 open source packages ship an affected version, including mezzanine and Mezzanine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mezzanine` | PyPI | All versions | 6.1.1 |
| `mezzanine` | PyPI | All versions | 6.1.1 |
| `Mezzanine` | PyPI | All versions | 6.1.1 |

Products: Jupo Mezzanine.

## How do I fix CVE-2025-6050?

Upgrade mezzanine to 6.1.1 or later.

## Is CVE-2025-6050 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6050 exists.

## Other vulnerabilities in jupo mezzanine

- [CVE-2024-25169](https://insights.sbomify.com/CVE-2024-25169/): Mezzanine allows attackers to bypass access control mechanisms (critical 9.8)
- [CVE-2024-25170](https://insights.sbomify.com/CVE-2024-25170/): Mezzanine allows attackers to bypass access controls via manipulating the Host header (critical 9.1)
- [CVE-2025-29573](https://insights.sbomify.com/CVE-2025-29573/): Mezzanine CMS Cross-Site Scripting (XSS) vulnerability (medium 6.1)
- [CVE-2020-19002](https://insights.sbomify.com/CVE-2020-19002/): Mezzanine Cross Site Scripting (XSS) vulnerability (medium 6.1)
- [CVE-2025-50481](https://insights.sbomify.com/CVE-2025-50481/): Mezzanine CMS vulnerable to Cross-site Scripting (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6050 and fix it if it is affected.

What it is: CVE-2025-6050 is a medium-severity cross-site scripting vulnerability in jupo mezzanine, published on 17 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6050 exists.

Affected packages and fixed versions:
- mezzanine (PyPI): affected all versions; fixed in 6.1.1
- mezzanine (PyPI): affected all versions; fixed in 6.1.1
- Mezzanine (PyPI): affected all versions; fixed in 6.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6050/ (Markdown: https://insights.sbomify.com/CVE-2025-6050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6050
- OSV: https://osv.dev/vulnerability/CVE-2025-6050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6050/
Summaries are generated and may contain mistakes; the official description above is the record.
