CVE-2025-61140 JSONPath vulnerable to Prototype Pollution due to insufficient input validation of object keys in lib/index.js

Critical 9.8 Published Updated

Prototype pollution in the jsonpath library allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-61140?

CVE-2025-61140 is a critical unsafe deserialization vulnerability in n/a, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The value function in jsonpath 1.1.1 lib/index.js is vulnerable to Prototype Pollution.

Weakness: CWE-502, CWE-1321

Which versions are affected by CVE-2025-61140?

2 open source packages ship an affected version, including jsonpath. It affects 1 product.

PackageAffectedFixed in
jsonpath npmAll versions1.2.0
jsonpath npmAll versions1.2.0

Products include Dchester Jsonpath.

How do I fix CVE-2025-61140?

Upgrade jsonpath to 1.2.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-61140 being exploited?

There is no known exploitation of CVE-2025-61140 in the wild and no public exploit code.

Sources

Also known as GHSA-6c59-mwgh-r2x6, ROOT-APP-NPM-CVE-2025-61140.

Is CVE-2025-61140 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free