{"answers":{"affected":"3 open source packages ship an affected version, including pg8000.","exploited":"There is no known exploitation of CVE-2025-61385 in the wild and no public exploit code.","fix":"Upgrade pg8000 to 1.31.5 or later.","what":"CVE-2025-61385 is a critical SQL injection vulnerability in n/a, published on 27 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-61385 and fix it if it is affected.\n\nWhat it is: CVE-2025-61385 is a critical SQL injection vulnerability in n/a, published on 27 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-61385 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pg8000 (PyPI): affected all versions; fixed in 1.31.5\n- pg8000 (PyPI): affected all versions; fixed in 1.31.5\n- pg8000 (PyPI): affected all versions; fixed in 1.31.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61385/ (Markdown: https://insights.sbomify.com/CVE-2025-61385/index.md)","id":"CVE-2025-61385","markdown":"https://insights.sbomify.com/CVE-2025-61385/index.md","name":"CVE-2025-61385","record":{"aliases":["GHSA-wq2g-r956-j8cc","PYSEC-2026-1766"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python PostgreSQL library","requires_auth":"none","summary":"Remote attackers can execute arbitrary SQL commands via crafted input in the pg8000 library, potentially compromising database integrity and confidentiality.","user_interaction":"required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.6,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"SQL injection vulnerability in tlocke pg8000 1.31.4 allows remote attackers to execute arbitrary SQL commands via a specially crafted Python list input to function pg8000.native.literal.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pg8000 SQL injection vulnerability via a specially crafted Python list input","id":"CVE-2025-61385","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Piranha CMS vulnerable to stored cross-site scripting (XSS)","id":"CVE-2025-61413"},"packages":[{"ecosystem":"PyPI","fixed":["1.31.5"],"introduced":["0"],"last_affected":[],"package":"pg8000","purl":null,"source":"GHSA-wq2g-r956-j8cc"},{"ecosystem":"PyPI","fixed":["1.31.5"],"introduced":["0"],"last_affected":[],"package":"pg8000","purl":"pkg:pypi/pg8000","source":"GHSA-wq2g-r956-j8cc"},{"ecosystem":"PyPI","fixed":["1.31.5"],"introduced":["0"],"last_affected":[],"package":"pg8000","purl":"pkg:pypi/pg8000","source":"PYSEC-2026-1766"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2025-61330"},"products":["n/a"],"published":"2025-10-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-28","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary SQL commands via crafted input in the pg8000 library, potentially compromising database integrity and confidentiality.","url":"https://insights.sbomify.com/CVE-2025-61385/"}