# CVE-2025-61385: pg8000 SQL injection vulnerability via a specially crafted Python list input

> Remote attackers can execute arbitrary SQL commands via crafted input in the pg8000 library, potentially compromising database integrity and confidentiality.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Oct 2025
- **Updated:** 28 Oct 2025
- **Also known as:** GHSA-wq2g-r956-j8cc, PYSEC-2026-1766

## What is CVE-2025-61385?

CVE-2025-61385 is a critical SQL injection vulnerability in n/a, published on 27 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SQL injection vulnerability in tlocke pg8000 1.31.4 allows remote attackers to execute arbitrary SQL commands via a specially crafted Python list input to function pg8000.native.literal.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-61385?

3 open source packages ship an affected version, including pg8000.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pg8000` | PyPI | All versions | 1.31.5 |
| `pg8000` | PyPI | All versions | 1.31.5 |
| `pg8000` | PyPI | All versions | 1.31.5 |

## How do I fix CVE-2025-61385?

Upgrade pg8000 to 1.31.5 or later.

## Is CVE-2025-61385 being exploited?

There is no known exploitation of CVE-2025-61385 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61385 and fix it if it is affected.

What it is: CVE-2025-61385 is a critical SQL injection vulnerability in n/a, published on 27 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-61385 in the wild and no public exploit code.

Affected packages and fixed versions:
- pg8000 (PyPI): affected all versions; fixed in 1.31.5
- pg8000 (PyPI): affected all versions; fixed in 1.31.5
- pg8000 (PyPI): affected all versions; fixed in 1.31.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61385/ (Markdown: https://insights.sbomify.com/CVE-2025-61385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61385
- OSV: https://osv.dev/vulnerability/CVE-2025-61385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61385/
Summaries are generated and may contain mistakes; the official description above is the record.
