CVE-2025-6140 spdlog pattern_formatter-inl.h scoped_padder resource consumption
A local attacker can cause resource consumption in the spdlog library via the scoped_padder function, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6140?
CVE-2025-6140 is a medium-severity denial of service vulnerability in spdlog, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
A vulnerability, which was classified as problematic, was found in spdlog up to 1.15.1. This affects the function scoped_padder in the library include/spdlog/pattern_formatter-inl.h. The manipulation leads to resource consumption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.15.2 is able to address this issue. The identifier of the patch is 10320184df1eb4638e253a34b1eb44ce78954094. It is recommended to upgrade the affected component.
Which versions are affected by CVE-2025-6140?
It affects 1 product.
Linux distribution packages (1)
spdlog openSUSE:Tumbleweed | All versions | 1.15.3-2.1 |
Products include Gabime Spdlog.
How do I fix CVE-2025-6140?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-6140 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6140 exists.
Sources
Also known as AZL-64070, DEBIAN-CVE-2025-6140, GHSA-jp5g-8qgr-gfpx, MGASA-2025-0294, UBUNTU-CVE-2025-6140, openSUSE-SU-2025:15297-1.