{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6140 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-6140 is a medium-severity denial of service vulnerability in spdlog, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6140 and fix it if it is affected.\n\nWhat it is: CVE-2025-6140 is a medium-severity denial of service vulnerability in spdlog, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6140 exists.\n\nAffected product: spdlog. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6140/ (Markdown: https://insights.sbomify.com/CVE-2025-6140/index.md)","id":"CVE-2025-6140","markdown":"https://insights.sbomify.com/CVE-2025-6140/index.md","name":"CVE-2025-6140","record":{"aliases":["AZL-64070","DEBIAN-CVE-2025-6140","GHSA-jp5g-8qgr-gfpx","MGASA-2025-0294","UBUNTU-CVE-2025-6140","openSUSE-SU-2025:15297-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"C++ logging library","requires_auth":"low_privilege","summary":"A local attacker can cause resource consumption in the spdlog library via the scoped_padder function, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"spdlog","vendor":"gabime"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"A vulnerability, which was classified as problematic, was found in spdlog up to 1.15.1. This affects the function scoped_padder in the library include/spdlog/pattern_formatter-inl.h. The manipulation leads to resource consumption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.15.2 is able to address this issue. The identifier of the patch is 10320184df1eb4638e253a34b1eb44ce78954094. It is recommended to upgrade the affected component.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"spdlog pattern_formatter-inl.h scoped_padder resource consumption","id":"CVE-2025-6140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":1,"n_references":7,"next":{"headline":"GNU ncurses parse_entry.c postprocess_termcap stack-based overflow","id":"CVE-2025-6141"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.15.3-2.1"],"introduced":["0"],"last_affected":[],"package":"spdlog","purl":"pkg:rpm/opensuse/spdlog\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15297-1"}],"prev":{"headline":"TOTOLINK T10 shadow.sample hard-coded password","id":"CVE-2025-6139"},"products":["spdlog"],"published":"2025-06-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["n/a"]},"summary":"A local attacker can cause resource consumption in the spdlog library via the scoped_padder function, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2025-6140/"}