# CVE-2025-6140: spdlog pattern_formatter-inl.h scoped_padder resource consumption

> A local attacker can cause resource consumption in the spdlog library via the scoped_padder function, leading to denial of service.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2025
- **Updated:** 17 Jun 2025
- **Also known as:** AZL-64070, DEBIAN-CVE-2025-6140, GHSA-jp5g-8qgr-gfpx, MGASA-2025-0294, UBUNTU-CVE-2025-6140, openSUSE-SU-2025:15297-1

## What is CVE-2025-6140?

CVE-2025-6140 is a medium-severity denial of service vulnerability in spdlog, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability, which was classified as problematic, was found in spdlog up to 1.15.1. This affects the function scoped_padder in the library include/spdlog/pattern_formatter-inl.h. The manipulation leads to resource consumption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.15.2 is able to address this issue. The identifier of the patch is 10320184df1eb4638e253a34b1eb44ce78954094. It is recommended to upgrade the affected component.

Weakness: CWE-404 (Improper Resource Shutdown or Release), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-6140?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spdlog` | openSUSE:Tumbleweed | All versions | 1.15.3-2.1 |

Products: Gabime Spdlog.

## How do I fix CVE-2025-6140?

Upgrade to a fixed version.

## Is CVE-2025-6140 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6140 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6140 and fix it if it is affected.

What it is: CVE-2025-6140 is a medium-severity denial of service vulnerability in spdlog, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6140 exists.

Affected product: spdlog. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6140/ (Markdown: https://insights.sbomify.com/CVE-2025-6140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6140
- OSV: https://osv.dev/vulnerability/CVE-2025-6140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6140/
Summaries are generated and may contain mistakes; the official description above is the record.
