{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-6141 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-6141 is a medium-severity memory corruption vulnerability in GNU ncurses, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6141 and fix it if it is affected.\n\nWhat it is: CVE-2025-6141 is a medium-severity memory corruption vulnerability in GNU ncurses, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-6141 in the wild and no public exploit code.\n\nAffected product: GNU ncurses. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6141/ (Markdown: https://insights.sbomify.com/CVE-2025-6141/index.md)","id":"CVE-2025-6141","markdown":"https://insights.sbomify.com/CVE-2025-6141/index.md","name":"CVE-2025-6141","record":{"aliases":["AZL-64139","BELL-CVE-2025-6141","DEBIAN-CVE-2025-6141","ECHO-d3c9-c3e9-90e8","GHSA-wfwf-ggr2-rpjf","JLSEC-2026-454","OESA-2025-1851","ROOT-OS-DEBIAN-11-CVE-2025-6141","ROOT-OS-DEBIAN-12-CVE-2025-6141","ROOT-OS-DEBIAN-13-CVE-2025-6141","UBUNTU-CVE-2025-6141","USN-8709-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GNU ncurses library","requires_auth":"low_privilege","summary":"A local attacker can exploit a stack-based buffer overflow in GNU ncurses to potentially execute arbitrary code or cause a denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability has been found in GNU ncurses up to 6.5-20250322 and classified as problematic. This vulnerability affects the function postprocess_termcap of the file tinfo/parse_entry.c. The manipulation leads to stack-based buffer overflow. The attack needs to be approached locally. Upgrading to version 6.5-20250329 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GNU ncurses parse_entry.c postprocess_termcap stack-based overflow","id":"CVE-2025-6141","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":0,"n_references":8,"next":{"headline":"Intera InHire server-side request forgery","id":"CVE-2025-6142"},"packages":[],"prev":{"headline":"spdlog pattern_formatter-inl.h scoped_padder resource consumption","id":"CVE-2025-6140"},"products":["ncurses"],"published":"2025-06-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-02","vendors":["GNU"]},"summary":"A local attacker can exploit a stack-based buffer overflow in GNU ncurses to potentially execute arbitrary code or cause a denial of service.","url":"https://insights.sbomify.com/CVE-2025-6141/"}