CVE-2025-61457 code16 Sharp vulnerable to Cross Site Scripting (XSS)

Medium 6.1 Published Updated

Cross-site scripting vulnerability in Sharp form upload field allows attackers to inject malicious scripts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-61457?

CVE-2025-61457 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

code16 Sharp v9.6.6 is vulnerable to Cross Site Scripting (XSS) src/Form/Fields/SharpFormUploadField.php.

Weakness: CWE-79

Which versions are affected by CVE-2025-61457?

2 open source packages ship an affected version, including code16/sharp.

PackageAffectedFixed in
code16/sharp PackagistAll versions9.7.0
code16/sharp PackagistAll versions9.7.0

How do I fix CVE-2025-61457?

Upgrade code16/sharp to 9.7.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-61457 being exploited?

There is no known exploitation of CVE-2025-61457 in the wild and no public exploit code.

Sources

Also known as GHSA-9778-v769-qvjf.

Is CVE-2025-61457 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free