# CVE-2025-61457: code16 Sharp vulnerable to Cross Site Scripting (XSS)

> Cross-site scripting vulnerability in Sharp form upload field allows attackers to inject malicious scripts.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Oct 2025
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-9778-v769-qvjf

## What is CVE-2025-61457?

CVE-2025-61457 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

code16 Sharp v9.6.6 is vulnerable to Cross Site Scripting (XSS) src/Form/Fields/SharpFormUploadField.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-61457?

2 open source packages ship an affected version, including code16/sharp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code16/sharp` | Packagist | All versions | 9.7.0 |
| `code16/sharp` | Packagist | All versions | 9.7.0 |

## How do I fix CVE-2025-61457?

Upgrade code16/sharp to 9.7.0 or later.

## Is CVE-2025-61457 being exploited?

There is no known exploitation of CVE-2025-61457 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61457 and fix it if it is affected.

What it is: CVE-2025-61457 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-61457 in the wild and no public exploit code.

Affected packages and fixed versions:
- code16/sharp (Packagist): affected all versions; fixed in 9.7.0
- code16/sharp (Packagist): affected all versions; fixed in 9.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61457/ (Markdown: https://insights.sbomify.com/CVE-2025-61457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61457
- OSV: https://osv.dev/vulnerability/CVE-2025-61457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61457/
Summaries are generated and may contain mistakes; the official description above is the record.
