# CVE-2025-61524: Casdoor is vulnerable to Improper Authorization

> Authenticated administrators can bypass permission checks to modify organizations or applications by manipulating URLs, requiring an upgrade to Casdoor.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2025
- **Updated:** 5 Jul 2026
- **Also known as:** GHSA-5m9m-j5p7-m7f9, GO-2025-4026

## What is CVE-2025-61524?

CVE-2025-61524 is a high-severity authentication bypass vulnerability in n/a, published on 8 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue in the permission verification module and organization/application editing interface in Casdoor v2.26.0 and before, and fixed in v.2.63.0, allows remote authenticated administrators of any organization within the system to bypass the system's permission verification mechanism by directly concatenating URLs after login

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-61524?

3 open source packages ship an affected version, including github.com/casdoor/casdoor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/casdoor/casdoor` | Go | All versions | None |
| `github.com/casdoor/casdoor` | Go | All versions | 2.63.0 |
| `github.com/casdoor/casdoor` | Go | All versions | 2.63.0 |

## How do I fix CVE-2025-61524?

Upgrade github.com/casdoor/casdoor to 2.63.0 or later.

## Is CVE-2025-61524 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61524 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61524 and fix it if it is affected.

What it is: CVE-2025-61524 is a high-severity authentication bypass vulnerability in n/a, published on 8 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61524 exists.

Affected packages and fixed versions:
- github.com/casdoor/casdoor (Go): affected all versions; no fix listed
- github.com/casdoor/casdoor (Go): affected all versions; fixed in 2.63.0
- github.com/casdoor/casdoor (Go): affected all versions; fixed in 2.63.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61524/ (Markdown: https://insights.sbomify.com/CVE-2025-61524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61524
- OSV: https://osv.dev/vulnerability/CVE-2025-61524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61524/
Summaries are generated and may contain mistakes; the official description above is the record.
