# CVE-2025-61587: Weblate integration with Anubis can lead to Open Redirect via redir parameter

> Attackers can redirect users to malicious sites via the redir parameter when Weblate is configured with Anubis and REDIRECT_DOMAINS is unset.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-3xhv-r4gx-xw99, PYSEC-2025-269, openSUSE-SU-2025:15615-1

## What is CVE-2025-61587?

CVE-2025-61587 is a low-severity vulnerability in WeblateOrg weblate, published on 1 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Weblate is a web based localization tool. An open redirect exists in versions 5.13.2 and below via the redir parameter on .within.website when Weblate is configured with Anubis and REDIRECT_DOMAINS is not set. An attacker can craft a URL on the legitimate domain that redirects a victim to an attacker-controlled site. The redirect can also be used to initiate drive-by downloads (redirecting to a URL that serves a malicious file), increasing the risk to end users. This issue is fixed in version 5.13.3.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-1395 (Dependency on Vulnerable Third-Party Component)

## Which versions are affected by CVE-2025-61587?

1 open source package ship an affected version, including weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.13.3 |
| `weblate` | openSUSE:Tumbleweed | All versions | 5.13.3-1.1 |

Products: Weblate Weblate.

## How do I fix CVE-2025-61587?

Upgrade weblate to 5.13.3 or later.

## Is CVE-2025-61587 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61587 exists.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61587 and fix it if it is affected.

What it is: CVE-2025-61587 is a low-severity vulnerability in WeblateOrg weblate, published on 1 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61587 exists.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61587/ (Markdown: https://insights.sbomify.com/CVE-2025-61587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61587
- OSV: https://osv.dev/vulnerability/CVE-2025-61587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61587/
Summaries are generated and may contain mistakes; the official description above is the record.
