CVE-2025-61594 URI Credential Leakage Bypass over CVE-2025-27221
Attackers can leak sensitive credentials from URIs when using the addition operator, exposing user passwords in Ruby applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61594?
CVE-2025-61594 is a low-severity vulnerability in ruby uri, published on 30 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.
Which versions are affected by CVE-2025-61594?
6 open source packages ship an affected version, including uri. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
uri RubyGems | All versions | 0.12.5 |
uri RubyGems | All versions | 0.12.5 |
uri RubyGems | From 0.13.0 | 0.13.3 |
uri RubyGems | From 0.13.0 | 0.13.3 |
uri RubyGems | From 1.0.0 | 1.0.4 |
uri RubyGems | From 1.0.0 | 1.0.4 |
Linux distribution packages (2)
ruby3.4 openSUSE:Tumbleweed | All versions | 3.4.7-1.1 |
rubygem-uri openSUSE:Tumbleweed | All versions | 1.1.1-1.1 |
Products include Ruby-Lang Uri.
How do I fix CVE-2025-61594?
Upgrade uri to a fixed version for your release line: 0.12.5, 0.13.3 or 1.0.4.
Is CVE-2025-61594 being exploited?
There is no known exploitation of CVE-2025-61594 in the wild and no public exploit code.
Other vulnerabilities in ruby uri
Sources
Also known as ALPINE-CVE-2025-61594, AZL-73356, AZL-73391, BELL-CVE-2025-61594, CLEANSTART-2026-JW72308, CLEANSTART-2026-TF01901 and 26 more.