{"answers":{"affected":"6 open source packages ship an affected version, including uri. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-61594 in the wild and no public exploit code.","fix":"Upgrade uri to a fixed version for your release line: 0.12.5, 0.13.3 or 1.0.4.","what":"CVE-2025-61594 is a low-severity vulnerability in ruby uri, published on 30 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61594 and fix it if it is affected.\n\nWhat it is: CVE-2025-61594 is a low-severity vulnerability in ruby uri, published on 30 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-61594 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uri (RubyGems): affected all versions; fixed in 0.12.5\n- uri (RubyGems): affected all versions; fixed in 0.12.5\n- uri (RubyGems): affected from 0.13.0; fixed in 0.13.3\n- uri (RubyGems): affected from 0.13.0; fixed in 0.13.3\n- uri (RubyGems): affected from 1.0.0; fixed in 1.0.4\n- uri (RubyGems): affected from 1.0.0; fixed in 1.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61594/ (Markdown: https://insights.sbomify.com/CVE-2025-61594/index.md)","id":"CVE-2025-61594","markdown":"https://insights.sbomify.com/CVE-2025-61594/index.md","name":"CVE-2025-61594","record":{"aliases":["ALPINE-CVE-2025-61594","AZL-73356","AZL-73391","BELL-CVE-2025-61594","CLEANSTART-2026-JW72308","CLEANSTART-2026-TF01901","DEBIAN-CVE-2025-61594","ECHO-708d-96ad-f256","GHSA-j4pr-3wm6-xx2r","MINI-25qq-hmr8-73px","MINI-4mjv-cw2f-fw6q","MINI-5c36-m223-r44m","MINI-668j-f75q-q9p8","MINI-7xjr-7x5r-9xfq","MINI-83ww-w78w-3q6r","MINI-9f77-r6r8-rvp7","MINI-c973-6qqv-hhwm","MINI-f973-wxpm-gc3h","MINI-gc93-7v94-m4q5","MINI-jh2q-crf3-jw37","MINI-p633-qwjc-cc7f","MINI-pf3w-8rqp-7qm9","MINI-pvhj-58h5-m5v2","MINI-q3cw-8378-qmrm","MINI-v92q-jmj7-jh56","MINI-w8f3-j53j-v4wg","MINI-wjfg-j9jp-w55r","MINI-wphm-f495-f98h","UBUNTU-CVE-2025-61594","USN-8137-1","openSUSE-SU-2025:15614-1","openSUSE-SU-2026:11204-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby URI library","requires_auth":"none","summary":"Attackers can leak sensitive credentials from URIs when using the addition operator, exposing user passwords in Ruby applications.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"uri","vendor":"ruby-lang"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-212","name":"Improper Removal of Sensitive Information Before Storage or Transfer"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.","ecosystems":["RubyGems","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"URI Credential Leakage Bypass over CVE-2025-27221","id":"CVE-2025-61594","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":8,"n_references":4,"next":{"headline":"MANTRA tx gas limit is not enforced in send hooks","id":"CVE-2025-61595"},"packages":[{"ecosystem":"RubyGems","fixed":["0.12.5"],"introduced":["0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-j4pr-3wm6-xx2r"},{"ecosystem":"RubyGems","fixed":["0.12.5"],"introduced":["0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-j4pr-3wm6-xx2r"},{"ecosystem":"RubyGems","fixed":["0.13.3"],"introduced":["0.13.0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-j4pr-3wm6-xx2r"},{"ecosystem":"RubyGems","fixed":["0.13.3"],"introduced":["0.13.0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-j4pr-3wm6-xx2r"},{"ecosystem":"RubyGems","fixed":["1.0.4"],"introduced":["1.0.0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-j4pr-3wm6-xx2r"},{"ecosystem":"RubyGems","fixed":["1.0.4"],"introduced":["1.0.0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-j4pr-3wm6-xx2r"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.4.7-1.1"],"introduced":["0"],"last_affected":[],"package":"ruby3.4","purl":"pkg:rpm/opensuse/ruby3.4\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15614-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.1.1-1.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-uri","purl":"pkg:rpm/opensuse/rubygem-uri\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11204-1"}],"prev":{"headline":"Cursor CLI Agent: Sensitive File Overwrite Bypass","id":"CVE-2025-61593"},"products":["uri"],"published":"2025-12-30","related":[{"cvss_score":5.3,"headline":"URI gem has ReDoS vulnerability","id":"CVE-2023-36617","kev_date_added":null,"published":"2023-06-29"},{"cvss_score":3.2,"headline":"URI allows for userinfo Leakage in URI#join, URI#merge, and URI#+","id":"CVE-2025-27221","kev_date_added":null,"published":"2025-03-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["ruby"]},"summary":"Attackers can leak sensitive credentials from URIs when using the addition operator, exposing user passwords in Ruby applications.","url":"https://insights.sbomify.com/CVE-2025-61594/"}