# CVE-2025-61595: MANTRA tx gas limit is not enforced in send hooks

> Attackers can cause denial of service by exploiting unenforced gas limits in send hooks, leading to exponential gas consumption via recursive calls.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2025
- **Updated:** 2 Oct 2025
- **Also known as:** GHSA-qwvm-wqq8-8j69, GO-2025-3997

## What is CVE-2025-61595?

CVE-2025-61595 is a high-severity denial of service vulnerability in MANTRA-Chain mantrachain, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MANTRA is a purpose-built RWA Layer 1 Blockchain, capable of adherence to real world regulatory requirements. Versions 4.0.1 and below do not enforce the tx gas limit in its send hooks. Send hooks can spend more gas than what remains in tx, combined with recursive calls in the wasm contract, potentially amplifying the gas consumption exponentially. This is fixed in version 4.0.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-61595?

12 open source packages ship an affected version, including github.com/MANTRA-Chain/mantrachain, github.com/MANTRA-Chain/mantrachain/v2 and github.com/MANTRA-Chain/mantrachain/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/MANTRA-Chain/mantrachain` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain/v2` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain/v2` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain/v2` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain/v3` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain/v3` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain/v3` | Go | All versions | None |
| `github.com/MANTRA-Chain/mantrachain/v4` | Go | All versions | 4.0.2 |
| `github.com/MANTRA-Chain/mantrachain/v4` | Go | All versions | 4.0.2 |
| `github.com/MANTRA-Chain/mantrachain/v4` | Go | All versions | 4.0.2 |

## How do I fix CVE-2025-61595?

Upgrade to a fixed version.

## Is CVE-2025-61595 being exploited?

There is no known exploitation of CVE-2025-61595 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61595 and fix it if it is affected.

What it is: CVE-2025-61595 is a high-severity denial of service vulnerability in MANTRA-Chain mantrachain, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61595 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/MANTRA-Chain/mantrachain (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain/v2 (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain/v2 (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain/v2 (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain/v3 (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain/v3 (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain/v3 (Go): affected all versions; no fix listed
- github.com/MANTRA-Chain/mantrachain/v4 (Go): affected all versions; fixed in 4.0.2
- github.com/MANTRA-Chain/mantrachain/v4 (Go): affected all versions; fixed in 4.0.2
- github.com/MANTRA-Chain/mantrachain/v4 (Go): affected all versions; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61595/ (Markdown: https://insights.sbomify.com/CVE-2025-61595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61595
- OSV: https://osv.dev/vulnerability/CVE-2025-61595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61595/
Summaries are generated and may contain mistakes; the official description above is the record.
