CVE-2025-61597 Emlog Pro is vulnerable to stored XSS attack through HTML template injection

High 7.6 Published Updated

Attackers can inject malicious scripts into mail templates, leading to admin session theft and account takeover upon visiting the settings page.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-61597?

CVE-2025-61597 is a high-severity cross-site scripting vulnerability in Emlog Emlog, published on 3 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Emlog is an open source website building system. In versions 2.5.21 and below, an HTML template injection allows stored cross‑site scripting (XSS) via the mail template settings. Once a malicious payload is saved, any subsequent visit to the settings page in an authenticated admin context will execute attacker‑controlled JavaScript, enabling session/token theft and full admin account takeover. This issue is fixed in version 2.5.22.

Weakness: CWE-79

Which versions are affected by CVE-2025-61597?

It affects 1 product.

Products include Emlog Emlog.

How do I fix CVE-2025-61597?

No fix has been published for CVE-2025-61597 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-61597 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61597 exists.

All Emlog Emlog vulnerabilities

Sources

Also known as GHSA-hj97-hp2c-6m4m.

Is CVE-2025-61597 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free