# CVE-2025-61598: Discourse is missing Cache-Control response header on error responses

> Missing Cache-Control headers on error responses allow proxies to cache sensitive data, potentially leading to cache poisoning and information disclosure.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2025
- **Updated:** 29 Oct 2025
- **Also known as:** BIT-discourse-2025-61598, GHSA-jp9x-wwv6-cv3j

## What is CVE-2025-61598?

CVE-2025-61598 is a medium-severity vulnerability in Discourse Discourse, published on 28 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source discussion platform. Version before 3.6.2 and 3.6.0.beta2, default Cache-Control response header with value no-store, no-cache was missing from error responses. This may caused unintended caching of those responses by proxies potentially leading to cache poisoning attacks. This vulnerability is fixed in 3.6.2 and 3.6.0.beta2.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2025-61598?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.6.2 |

Products: Discourse Discourse.

## How do I fix CVE-2025-61598?

Upgrade discourse to 3.6.2 or later.

## Is CVE-2025-61598 being exploited?

There is no known exploitation of CVE-2025-61598 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61598 and fix it if it is affected.

What it is: CVE-2025-61598 is a medium-severity vulnerability in Discourse Discourse, published on 28 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61598 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61598/ (Markdown: https://insights.sbomify.com/CVE-2025-61598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61598
- OSV: https://osv.dev/vulnerability/CVE-2025-61598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61598/
Summaries are generated and may contain mistakes; the official description above is the record.
