# CVE-2025-61600: Unbounded Memory Allocation in Stalwart IMAP parser

> Remote attackers can exhaust server memory via the IMAP parser, causing a denial of service in Stalwart mail servers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2025
- **Updated:** 3 Oct 2025
- **Also known as:** GHSA-8jqj-qj5p-v5rr

## What is CVE-2025-61600?

CVE-2025-61600 is a high-severity denial of service vulnerability in stalwartlabs stalwart, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Stalwart is a mail and collaboration server. Versions 0.13.3 and below contain an unbounded memory allocation vulnerability in the IMAP protocol parser which allows remote attackers to exhaust server memory, potentially triggering the system's out-of-memory (OOM) killer and causing a denial of service. The CommandParser implementation enforces size limits on its dynamic buffer in most parsing states, but several state handlers omit these validation checks. This issue is fixed in version 0.13.4. A workaround for this issue is to implement rate limiting and connection monitoring at the network level, however this does not provide complete protection.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-61600?


## How do I fix CVE-2025-61600?

No fix has been published for CVE-2025-61600 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-61600 being exploited?

There is no known exploitation of CVE-2025-61600 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61600 and fix it if it is affected.

What it is: CVE-2025-61600 is a high-severity denial of service vulnerability in stalwartlabs stalwart, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61600 in the wild and no public exploit code.

Affected product: stalwartlabs stalwart. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61600/ (Markdown: https://insights.sbomify.com/CVE-2025-61600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61600
- OSV: https://osv.dev/vulnerability/CVE-2025-61600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61600/
Summaries are generated and may contain mistakes; the official description above is the record.
