CVE-2025-61622 Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory
An attacker can achieve remote code execution by crafting malicious data streams that trigger unsafe pickle deserialization in the pyfory library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61622?
CVE-2025-61622 is a critical unsafe deserialization vulnerability in Apache Fory, published on 1 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution.
Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
Weakness: CWE-502
Which versions are affected by CVE-2025-61622?
6 open source packages ship an affected version, including pyfory and pyfury. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pyfory PyPI | From 0.12.0 | 0.12.3 |
pyfory PyPI | From 0.12.0 | 0.12.3 |
pyfory PyPI | From 0.12.0 | 0.12.3 |
pyfury PyPI | From 0.1.0 to 0.10.3 | None |
pyfury PyPI | From 0.1.0 to 0.10.3 | None |
pyfury PyPI | From 0.1.0 to 0.10.3 | None |
Products include Apache Fory.
How do I fix CVE-2025-61622?
Upgrade pyfory to 0.12.3 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2025-61622 being exploited?
There is no known exploitation of CVE-2025-61622 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Fory
- CVE-2026-71558 Apache Fory: Heap type confusion in C++ polymorphic smart-pointer deserialization
- CVE-2026-64606 Apache Fory, Apache Fory: Class-registration bypass through an auto-admitted SerializedLambda capturing interface
- CVE-2026-64608 Apache Fory: Heap type confusion and out-of-bounds read/write in C++ compatible-mode field-skip paths
- CVE-2026-48207 Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement
- CVE-2026-71560 Apache Fory: Out-of-bounds heap read in C++ struct deserializer tagged-int fast-path
Sources
Also known as GHSA-538v-3wq9-4h3r, PYSEC-2026-490, PYSEC-2026-491.