# CVE-2025-61622: Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory

> An attacker can achieve remote code execution by crafting malicious data streams that trigger unsafe pickle deserialization in the pyfory library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-538v-3wq9-4h3r, PYSEC-2026-490, PYSEC-2026-491

## What is CVE-2025-61622?

CVE-2025-61622 is a critical unsafe deserialization vulnerability in Apache Fory, published on 1 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution.

Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-61622?

6 open source packages ship an affected version, including pyfory and pyfury. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyfory` | PyPI | From 0.12.0 | 0.12.3 |
| `pyfory` | PyPI | From 0.12.0 | 0.12.3 |
| `pyfory` | PyPI | From 0.12.0 | 0.12.3 |
| `pyfury` | PyPI | From 0.1.0 to 0.10.3 | None |
| `pyfury` | PyPI | From 0.1.0 to 0.10.3 | None |
| `pyfury` | PyPI | From 0.1.0 to 0.10.3 | None |

Products: Apache Fory.

## How do I fix CVE-2025-61622?

Upgrade pyfory to 0.12.3 or later.

## Is CVE-2025-61622 being exploited?

There is no known exploitation of CVE-2025-61622 in the wild and no public exploit code.

Public exploit code:

- This PoC demonstrates the Remote Code Execution (RCE) vulnerability in  Apache Pyfory (versions 0.12.0-0.12.2 and legacy PyFury 0.1.0-0.10.3)  due to insecure pickle fallback deserialization (CVE-2025-61622). (github_poc): https://github.com/fa1consec/cve_2025_61622_poc

## Other vulnerabilities in Apache Fory

- [CVE-2026-71558](https://insights.sbomify.com/CVE-2026-71558/): Apache Fory: Heap type confusion in C++ polymorphic smart-pointer deserialization (critical 9.8)
- [CVE-2026-64606](https://insights.sbomify.com/CVE-2026-64606/): Apache Fory, Apache Fory: Class-registration bypass through an auto-admitted SerializedLambda capturing interface (critical 9.8)
- [CVE-2026-64608](https://insights.sbomify.com/CVE-2026-64608/): Apache Fory: Heap type confusion and out-of-bounds read/write in C++ compatible-mode field-skip paths (critical 9.8)
- [CVE-2026-48207](https://insights.sbomify.com/CVE-2026-48207/): Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement (critical 9.8)
- [CVE-2026-71560](https://insights.sbomify.com/CVE-2026-71560/): Apache Fory: Out-of-bounds heap read in C++ struct deserializer tagged-int fast-path (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61622 and fix it if it is affected.

What it is: CVE-2025-61622 is a critical unsafe deserialization vulnerability in Apache Fory, published on 1 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61622 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyfory (PyPI): affected from 0.12.0; fixed in 0.12.3
- pyfory (PyPI): affected from 0.12.0; fixed in 0.12.3
- pyfory (PyPI): affected from 0.12.0; fixed in 0.12.3
- pyfury (PyPI): affected from 0.1.0 up to 0.10.3; no fix listed
- pyfury (PyPI): affected from 0.1.0 up to 0.10.3; no fix listed
- pyfury (PyPI): affected from 0.1.0 up to 0.10.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61622/ (Markdown: https://insights.sbomify.com/CVE-2025-61622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61622
- OSV: https://osv.dev/vulnerability/CVE-2025-61622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61622/
Summaries are generated and may contain mistakes; the official description above is the record.
