CVE-2025-61623 Apache OFBiz: Reflected Cross-site Scripting
Attackers can execute arbitrary scripts in user browsers via reflected XSS in Apache OFBiz, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-61623?
CVE-2025-61623 is a medium-severity cross-site scripting vulnerability in Apache Ofbiz, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Reflected cross-site scripting vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: before 24.09.03.
Users are recommended to upgrade to version 24.09.03, which fixes the issue.
Weakness: CWE-79
Which versions are affected by CVE-2025-61623?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2025-61623?
No fix has been published for CVE-2025-61623 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-61623 being exploited?
There is no known exploitation of CVE-2025-61623 in the wild and no public exploit code.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-vw27-7cgv-4xfw.