{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-61659 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2025-61659 is a medium-severity vulnerability in magicmonty bash-git-prompt, published on 29 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61659 and fix it if it is affected.\n\nWhat it is: CVE-2025-61659 is a medium-severity vulnerability in magicmonty bash-git-prompt, published on 29 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-61659 in the wild and no public exploit code.\n\nAffected product: magicmonty bash-git-prompt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61659/ (Markdown: https://insights.sbomify.com/CVE-2025-61659/index.md)","id":"CVE-2025-61659","markdown":"https://insights.sbomify.com/CVE-2025-61659/index.md","name":"CVE-2025-61659","record":{"aliases":["GHSA-r225-6x7c-4q3h","openSUSE-SU-2025:15770-1","openSUSE-SU-2025:20130-1"],"analysis":{"component_type":"developer_tool","fix_type":"patch","impacts":["data_modify","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"bash-git-prompt","requires_auth":"none","summary":"An attacker can exploit a predictable temporary file name in bash-git-prompt to modify data or escalate privileges.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-377","name":"DEPRECATED: Insecure Temporary File"}],"description":"bash-git-prompt 2.6.1 through 2.7.1 insecurely uses the /tmp/git-index-private$$ file, which has a predictable name.","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Other in bash-git-prompt","id":"CVE-2025-61659","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Grub2: grub2: out-of-bounds write via malicious usb device","id":"CVE-2025-61661"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["2.7.1-bp160.2.1"],"introduced":["0"],"last_affected":[],"package":"bash-git-prompt","purl":"pkg:rpm/opensuse/bash-git-prompt\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2025:20130-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.7.1-4.1"],"introduced":["0"],"last_affected":[],"package":"bash-git-prompt","purl":"pkg:rpm/opensuse/bash-git-prompt\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15770-1"}],"prev":{"headline":"Special:GlobalContributions shows edits on wikis the viewer doesn't have access to","id":"CVE-2025-61658"},"products":["bash-git-prompt"],"published":"2025-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["magicmonty"]},"summary":"An attacker can exploit a predictable temporary file name in bash-git-prompt to modify data or escalate privileges.","url":"https://insights.sbomify.com/CVE-2025-61659/"}