CVE-2025-61668 @plone/volto vulnerable to potential DoS by invoking specific URL by anonymous user
An anonymous user can crash the Volto NodeJS server by visiting a specific URL, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61668?
CVE-2025-61668 is a high-severity denial of service vulnerability in plone volto, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Volto is a ReactJS-based frontend for the Plone Content Management System. Versions 16.34.0 and below, 17.0.0 through 17.22.1, 18.0.0 through 18.27.1, and 19.0.0-alpha.1 through 19.0.0-alpha.5, an anonymous user could cause the NodeJS server part of Volto to quit with an error when visiting a specific URL. This issue is fixed in versions 16.34.1, 17.22.2, 18.27.2 and 19.0.0-alpha.6.
Which versions are affected by CVE-2025-61668?
8 open source packages ship an affected version, including @plone/volto.
| Package | Affected | Fixed in |
|---|---|---|
@plone/volto npm | All versions | 16.34.1 |
@plone/volto npm | All versions | 16.34.1 |
@plone/volto npm | From 17.0.0 | 17.22.2 |
@plone/volto npm | From 17.0.0 | 17.22.2 |
@plone/volto npm | From 18.0.0 | 18.27.2 |
@plone/volto npm | From 18.0.0 | 18.27.2 |
2 more packages
@plone/volto npm | From 19.0.0-alpha.1 | 19.0.0-alpha.6 |
@plone/volto npm | From 19.0.0-alpha.1 | 19.0.0-alpha.6 |
How do I fix CVE-2025-61668?
Upgrade @plone/volto to a fixed version for your release line: 16.34.1, 17.22.2, 18.27.2 or 19.0.0-alpha.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-61668 being exploited?
There is no known exploitation of CVE-2025-61668 in the wild and no public exploit code.
Sources
Also known as GHSA-m8rj-ppph-mj33.